Produktionsfräse auf Isel Basis

Ein Baukasten-System mit genormten (Metall-)Bauteilen für Entwicklung und Prototyping von kleineren Maschinen. / A Metal Construction Set for prototyping and fast devolpment of small devices.
Antworten
Benutzeravatar
case
Beiträge: 730
Registriert: Mi 13. Jun 2012, 01:12

Produktionsfräse auf Isel Basis

Beitrag von case » Di 20. Feb 2018, 01:45

Dies ist ein Buildreport über Aufbau und Restauration einer alten Produktionsfräse basierend auf Isel Komponenten. Los gehts:

Der Adler ist gelandet. 😁 Habe die CNC-Fräse jetzt sicher zu mir transportiert, ziemlich dickes Monster (ca. 150x120cm) und wiegt rund 350Kg (ohne den Schaltschrank, der wiegt auch noch mal ca. 120Kg).

Schaltschrank:
Bild

Fräse von vorn:
Bild

Fräse von hinten:
Bild

Besonders schön war, dass wir das Teil komplett rübergekriegt haben und nicht vorher zerlegen mussten. Allein die Nutenplatte wiegt schon einiges. Die ist aus massivem Guss-Alu, 3cm dick und 120x90cm


n der Mitte sieht man die Antriebseinheit, die seitlich mit nem Servo-Motor über einen kruzen Zahnriemen verbunden ist.

Y-Antriebsachse mit Servo:
Bild

Und hier der Servo von der X-Achse (Portal)

X-Portalachse mit Servo:
Bild


Plan B sieht vor, die Servos gegen dicke Stepper auszutauschen, denn leider hab ich von Servos nicht das geringste bischen Ahnung ... und wenn man mal einen Blick in den Schaltschrank wirft, dann wird einem leicht schwindelig ....

Schaltschrank mit PA8000 CNC-Steuerung und zwei SImatic S7/200 f. Pneumatiksteuerung:
Bild

Im oberen Bereich ist ein Industrie-PC, genauer eine PA-8000-LW Steuerung. Dadrunter befindet sich die Ansteuerung der Pneumatik, die anstatt einer Z-Achse auf dem Portal sass .

Schaltschrank mit Amkasyn Ken5 Servo Treibern
Bild

Oben rechts ein Frequenzumrichter, daneben ein kleines Netzteil und unten die Servo-Treiber AMKASYN KEN5

Der Schaltschrank wird mit 380V Drehstrom versorgt und die Servos laufen mit 350V.


Und ich hab wie gesagt null plan von sowas ... die Chancen stehen gut, dass die Steuerung beim rumprobieren in Rauch aufgeht ... aber für den Fall gibts ja noch Plan B

Ich möchte aber natürlich gerne, wenns iiirgendwie geht, die Servos gerne ans laufen kriegen und die bestehende Konfiguration erhalten.

Das ist jetzt mal als erstes die große Challenge.

Immerhin ist schon mal nix explodiert, als ich den Schaltschrank mal mit 380V versorgt habe, d.h., die Festplatte hat den Transport wohl auch heil überstanden und das System versucht nun ein WIndows 2000 Professional zu booten.

Das Problem ist ... ich kann mich nicht einloggen. Ich hab zwar vom Vorbesitzer ein login und passwd genannt bekommen, aber damit funktioniert es nicht und das könnte daran liegen, dass die Anmeldung vorher über Netz bzw. namentlich das damalige Firmennetz erfolgte, welches bei mir aber nicht existiert.

Deswegen bin ich jetzt schon die ganze Zeit am rumprobieren, wie ich in das blöde WIndows2000 auf sonstige Weise reinkomme ... hab schon ein paar Taschenspielertricks ausprobiert, aber das schein haklbwegs gut abgesichert zu sein. Die fRage ist also, wie man das WIndows dennoch knacken kann.

Wahrscheinlich geht es nur auf die harte tour, man muss irgendwie von einem anderen System aus booten, entweder einem Linux oder einer Windows2000 installations-CD und dann die die bisherige Haupt-festplatte da dran mounten so dass man da schreibend drauf zugreifen kann.

Weiter bin ich noch nicht, weil im mom eher das Problem ist, das das Bios noch von 2003 ist und es fraglich ist, ob bootbare USB-Medien wie zB. Speichersticks überhaupt schon unterstützt werden.

Ich konnte diesbezüglich aber zumindest schon einen Teilerfolg erzielen, indem ich mein altes USB-CDROM dranhängen und im Bios auch konfigurieren konnte 😃😃😃

Damit haben wir einen Fuss in der Tür. Im Mom bootet der gerade ein Ubuntu-Live System von CDrom.

Die Fräse selbst schätze ich auf ungefähr 15 Jahre alt, es dürfte sich dabei um einen Vorläufer bzw. damalige Version von dem handeln, was heutzutage einer Isel Flatcom 5 M entspricht, also sowas:


https://www.isel.com/de/flatcom-serie-m.html


Wobei es sich allerdings um eine Sondermaschine handelt, die zwar auf dem Isel Grundtyp aufbaut aber modifiziert ist, d.h., in diesem Fall gab es anstatt einer Z-Achse die besagte Pneumatik.

Letztere ergibt nebenbei nettes Bastelmaterial, bestehend aus Pneumatik zylindern, mit denen in der Produktion irgendwelche Teile festgeklemmt wurden, auf die dann ein Bolzen aufgeschweisst wurde. Gesteuert wurde das mittels zwei Siemens Simatic SPS Module vom Typ S7-200 ... sehr weit verbreitet in der Industrie wenns um Automatisierung geht. Also quasi das, wofuer unsereiner normalerweise nen Arduino verwenden würde ... nur teurer 😁

Alternativ wäre noch die Möglichkeit, auf einer separaten Platte oder USB-Device ein paralleles System zu installieren und dort die ursprüngliche Platte dranzumounten, etwa unter Linux, womit man zumindest schon mal auf diese SAM-Datei zugreifen könnte und ev. mit nem linux-tool namens "chntpwd" passwörter neu setzen kann.

Oder irgendwie gehts glaubich auch mit ner Win2K-Installations-CD (die ich mir allerdings erst noch besorgen müsste) ... was auf jedenfall schonmal ein Pluspunkt dabei ist: Ich habe von dem alten Win2K was da bereits auf der Platte installiert ist die Installations-Keys !!! Irgendjemand war so schlau, nen Zettel mit den Keys etwas versteckt in den 19"-Schaltschrank reinzukleben 😁

Und ich hab sie im Rahmen einer detaillierten Untersuchung auch gefunden.

Wichtig ist jedenfalls schonmal, dass dieses uralte Bios von 2003 zumindest schonmal mein externes USB-CDROM-Laufwerk unterstützt (dessen ich mri im Vorfeld erst mal nicht so sicher war).

Ich konnte vorhin schon damit eine Ubuntu-CD booten und hab dann versucht die im Live-Modus laufen zu lassen. Das hat dann ewig gedauert und gerödelt, aber irgendwann kam dann tatsächlich auchd er Linux-Screen. Allerdings rödelte es dann noch weiter und irgendwann hat es sich dann aufgehängt.

Meine Hoffnung ist jetzt, dass dies ev. daran liegt, das der PC nur 256MB RAM hat, was eh schon nicht viel ist, aber beim Betrieb im Live-Modus (wo ja komplett alles ins Ram ausgelagert wird) erst recht zu Problemen führt ... ioch vermute dass die Kiste am swappen ist, weshalb das auch so lange gedauert hat mit dem rödeln (ca. 20 min).

D.h., mit nem etwas schlankeren Linux komme ich da hoffentlich einen Schritt weiter. Mal schauen.


yo folks 😊 Nachdem ich mir gestern die halbe Nacht bei minus 6°C den Arsch abgefroren habe (Werkstatt ist unbeheizt), ists mir gelungen in das WindowsNT der CNC-Steuerung reinzukommen. Zunächst nur als Gast, aber damit hatte ich nicht genug Rechte die Steuerungsanwendung zu starten. Es gibt da eigens nen User namens PA8000 (so heisst auch die Steuerung) für, aber dessen Passwd konnte ich noch nicht cracken. Dafür ist es mir aber gelungen den Administrator-Account zu knacken und wie es aussieht scheint die Anwendung darunter zu starten.

Zumindest versucht sie das wohl, steigt dann aber mit ner Fehlermeldung, dass ihr irgendein 5V Signal fehlt, wieder aus. OK, ich habe bislang auch noch nicht die Servos angeschlossen gehabt, das werd ich morgen mal probieren und vielleicht gehts dann weiter.

Allerdings befürchte ich, dass das fehlende Signal nicht von den Servos kommen könnte sondern von der Pneumatik. Die PA8000 steuert ja ausser den Servo-Treibern auch noch zwei Simatic S7/200 SPS an, welche die Pneumatik steuern. Die ist aber schon demontiert und werd ich auch wohl kaum rekonstruieren können. Wenn ich die nicht aus den Settings der Steuerung rausschmeissen kann könnte das die Sache nachhaltig blockieren.

Aber auch selbst wenn es gelänge, irgendwie die beiden Achsen zu bewegen kommen mir doch gewisse Zweifel. Die PA8000 ist zwar relativ gut bzw. umfangreich dokumentiert, aber gerade das lesen dieser Dokus lässt in mir den Verdacht aufkommen, das ich da in hundert Jahren nicht druchsteigen werde, selbst wenn hardwaremässig alles richtig angeschlossen wäre und liefe.

Das ist halt ne richtige Indtstriemaschine, da gibst wer weiss was für Standards und alles natürlich auf maximale Sicherheit ausgelegt, da gibts für jeden Pups ein eigenes Rückmeldungssignal und irgendwelche speziellen Zustände ... das machts alles ziemlich komplex und undurchschaubar für mich ... hat schon sicherlich seinen Grund, warum Leute dafür als Beruf mehrere Jahre Ausbildung benötigen.

Der Knackpunkt meiner Überlegungen ist, selbst wenn alles liefe müsste ich es am Ende noch irgendwie schaffen, die bislang noch fehlende Z-Achse in diese ganze Logik mit einzubinden. Von der PA8000 her an sich müsste es wohl gehen, zumindest ist da glaubich noch ein Port frei. Aber ich bezweifle, dass ich da jemals soweit durchsteige, dass ich ihm die irgendwie noch ne weitere Achse unterjubeln kann, die obendrein noch mit nem Stepper anstatt nem Servo betrieben wird. Wie gesagt, es gibt da zig Signale und alles ist ungeheuer komplex, so dass man gefühlt wahrscheinlich Jahre für braucht um das alles zu analysieren und da gezielt agieren zu können.

Insofern beginne ich mich doch so langsam mit Plan B anzufreunden, der darin besteht, die Servos abzuschrauben und durch Stepper zu ersetzen, auch wenn die natürlich nicht so viel Bums haben. Aber damit kenn ich mich genügend aus um die Sache sicher ans laufen bringen zu können, und dies auch mit weit weniger Gerätetechnischem Aufwand. Sprich, da reicht mir ein Arduino als Zentralsteuerung und ein dickes 48V Netzteil, anstatt nem 1,50m großen Schaltschrank mit tausend Frequenzumrichtern, Schützen, usw. Der Schaltschrank wird immerhin mit 380V versorgt, die Servos laufen mit 350V ... das ist etwas, das mich auch ein bissel nervös macht ;)

Wenn ich die Servos abschraube kann ich die ja weiterhin mit dem Schaltschrank in der gegebenen (und mutmasslich lauffähigen) Konfiguration belassen und wenn ich Zeit und Langeweile habe mal versuchen, da noch tiefer reinzusteigen ... oder man verwendet sie einfach gleich für etwas, das nur zwei Achsen hat, das wäre zB. perfekt für den Antrieb eines Torchtables, weil da eben nur in der Ebene in zwei Richtungen verfahren wird und die Höhe des Schneidbrenners autonom reguliert wird ... das ist ja im Grunde genau das, was ich für OSE-Dev entwickelt hatte.

Oder ich schlachte das aus und verwende die Teile für andere Zwecke, zB. könnte man aus dem Schaltschrank einen coolen, d.h. sehr großen Solarspeicher bauen, mit sagen wir mal 10KWh, so diese Größenordnung. 😁


Also unterm Strich zusammengefasst ist die Sache mit den Servos im Prinzip wahrscheinlich lauffähig, aber man müsste sich schon sehr gut damit auskennen und reinarbeiten, um da noch die dritte Achse zu integrieren. Aber auf der anderen Seite drängt es mich, das Ding und sei es auch nur irgendwie ans laufen zu bringen, damit ichs halt nutzen kann ... zB. um UniProKit-Teile damit zu produzieren, und das am liebsten schon vorgestern 😃


Letztlich ist ja noch nix verloren, wenn ich die Servos abschraube, man kann dann ja noch weiterhin an dem System arbeiten, ich könnte dann sogar den Schaltschrank hier in die Deele stellen, wo ich auch nen 380V Anschluss habe und es aber nicht ganz so bitterkalt ist 😁


So sieht das Ding übrigens aus, das ist jetzt nur die Seite mit der Servoansteuerung, vom Typ AMKasyn Ken5, (siehe www.deltaelektronik.dk/media/9556/07_ke_kw_eng.pdf) auf der anderen Seite befindet sich die PA8000 (Manuals dazu unter https://www.powerautomation.de/downloads/) und die ganze Pneumatikansteuerung (mittels zweier Simatic S7/200 SPS).

Und hier noch ein Bild vom Servo aus dem die Daten hervorgehen:
Bild

Es handelt sich hierbei um einen AMK DT4-2-10-R00 . Datenblatt dazu gibts hier: https://www.graessner.at/upload/4696799 ... DP-eng.pdf


Und hier nochmal ein closeup von den AMKasyn Treibern:
Bild

Nur mal um nen Eindruck von der Sache zu vermitteln 😃


Tja, ich sollte mich eigentlich auch lieber meinen Pflichten widmen und noch ein bischen Buchhaltung wegarbeiten, aber heute tu ich keinen Handschlag mehr. Könnte mich jetzt eh nicht drauf konzentrieren weil in meinem Kopf lauter Gedanken rumspuken, wie ich auf der Y-Achse nen Stepper-Motor befestigt kriege, d.h., aufgrund der beengten Platzverhältnisse muss ich da irgendwie eine Umlenkung mittels Zahnriemen hinsetzen.


Was man oben auf dem vierten foddo sehen kann. Links ist die Antriebsachse und rechts davon der Servo. In dem grauen Kästchen davor befindet sich die Umlenkung mittels Zahnriehmen.

Auf der X-Achse stellt sich die Sache einfacher dar, da kann ich den Stepper so anbringen, dass er quasi in den freien Raum reinragt und über eine Kuppplung direkt mit der Welle verbunden ist, aber hier geht das nicht, weil der verbleibende Platz zwischen der Achse und dem Rahmen nicht ausreichend ist ... darum muss ich den entweder danebensetzen, wie ja auch schon hier von der Fa. Isel praktiziert, oooder ich müsste die Antriebsachse kürzen ... aber das wäre echt jammerschade, das bring ich glaubich nicht übers Herz.

Und im übrigen würde die Riemenübersetzung noch die Möglichkeit einer Untersetzung durch eine kleinere Riemenscheibe bieten, damit hätte ich noch mehr Kraft auf dieser Achse, auch wenns dafür dann etwas langsamer wäre.

Joa, soviel erstmal dazu. Hoffentlich wirds bald mal wieder wärmer.
--- Man wächst nur, indem man etwas zuende bringt und etwas anderes beginnt ---

Mein Blog: http://makeable.de
OpenEcoLab-Charta: http://openecolab.de

Benutzeravatar
case
Beiträge: 730
Registriert: Mi 13. Jun 2012, 01:12

Re: Produktionsfräse auf Isel Basis

Beitrag von case » Sa 24. Feb 2018, 18:10

Kurzes Update zur Fräse: Durch manuelles editieren einer Datei mit Maschinenparametern konnte ich die 5V-Fehlermeldung quasi aushebeln und bin etwas weiter beim starten des Programms gekommen, allerdings kam dann ne andere Fehlermeldung, irgendwas mit 24V und das Spiel kann ewig so weitergehen. Darum hab ich mich, auch in Absprache mit Alex Shure, jetzt dazu entschlossen, den zweiten Weg zu gehen und dei Servos erstmal durch Stepper zu ersetzen um die Fräse zügig in Betrieb nehmen zu können. Mit den Servos kann man ja separat weiter rumprobieren und die dann ggflls. später nochmal wieder einbauen.

Es gilt jetzt also als erstes, für die lange Y-Achse einen kräftigen Stepper einzubauen. Diese Achse muss das ganze X-Achsen Portal incl. Z-Achse bewegen können deren Gesamtgewicht ich auf locker 60Kg schätzen würde.

Der Stepper, den ich mir dafür ausgesucht habe ist ein 34HS59-5004S von Stepperonline, mit 5A Phasenstrom, 13 Nm Haltemoment und 5Kg Gewicht ... also wirklich ein ziemlich fetter Klopper 😁

Obwohl als Lieferdatum 2. März angegeben war hat Stepperonline wirklich extrem schnell geliefert, so dass ich das Paket vorhin schon bekommen hab und Euch daher nun erste Foddos präsentieren kann.


Der Motor:

Bild
Bild


Der Treiber:

Bild
Bild


Das Netzteil:
Bild


Passend dazu hab ich noch als Treiber eine Leadshine MA860H Endstufe und ein 350W-Netzteil, das bis 60V bei 6A kann, geordert. Damit sollte wohl das maximale an Kraft aus dem Ding rauszuholen sein.

Ausserdem hab ich noch ein zweites 48V-Netzteil geordert, mit ebenfalls 350W und knapp 10A. Dieses ist gedacht für die X- und Z-Achse, wo ich meine beiden (bereits vorhandenen) 3Nm Stepper dranhängen will. Eigentlich hätte ich für die X-Achse lieber nen Nema23 mit 4Nm genommen, aber dafür reichte leider die Kohle nicht mehr, für dieses Paket hab ich jetzt 230,- EUR hingeblättert und dann kommt ja noch die komplette Z-Achse auf mich zu, da rechne ich grob mit nochmal locker 300,- EUR, mindestens.

Aber zumindest die aktuelle Lieferung hab ich optimal-günstig bekommen, Stepperonline hat nicht nur sehr günstige Preise, sondern scheint ausserdem auch ein rennomierter Laden zu sein, der in einschlägigen CNC-Foren einen guten Ruf geniesst.
--- Man wächst nur, indem man etwas zuende bringt und etwas anderes beginnt ---

Mein Blog: http://makeable.de
OpenEcoLab-Charta: http://openecolab.de

Antworten